poniedziałek, 16 kwietnia 2007

Flash Player 9.0.45

Należy obecnie od 10 lipca 2007 roku instalować wersję 9.0.47 Adobe Flash Player dla użytkowników Windowsa (o problemach z instalacją na Windows Vista poświecono odrębny wpis). Użytkownicy Linuxa moga instalować wersję 9.0.48 Adobe Flash Player.

Po "cichu" Adobe wprowadziło nową aktualizację Adobe Flash Playera do wersji 9.0.45 uzasadniając to wprowadzeniem Flasha CS3, który podobno generuje nową zawartość niezgodną z tym co oferuje Adobe Flex 2. I wprowadzono 3 poprawki. Po przejrzeniu blogów okazało się że do w ActionScript 3 można programować nowe pakiety odpowiedzialne za przekształcenia i za animację. Nico w swoim blogu w wpisie Flash CS3 swc for Flexbuilder dołączył komponent z Flash CS3 pozwalając programistom Flexa wykorzystywać nowe pakiety na przykład takie jak fl.motion czy fl.transitions. Więcej o tym można poczytać w artykule Flash Quick Starts: Programming with ActionScript 3.0

3 komentarze:

Mali pisze...

Dlaczego "po cichu"? Bylo z pare wpisow na MXNA

Michał Małaj pisze...

Mało o tym się dyskutuje :)

Mali pisze...

Eee, no bo w gruncie rzeczy "duzo" tam nie poprawili. http://www.adobe.com/support/documentation/en/flashplayer/9/releasenotes.html#fixes_9045

To co mnie martwi, to to, ze wszyscy klienci <r45 nie naciesza sie komponentami CS3:

New ActionScript 3.0 components for Flash CS3 Professional do not function correctly in versions prior to Flash Player 9.0.45.0.

Oczywiscie nie mowie tu o mainstreamie: uzytkownikach internetu, a o korporacjach, gdzie wyblagac instalacje flash playera na wszystkich maszynach pracownikow graniczy z cudem.
Pytanie czemu: czy niedzialanie komponentow musza koniecznie naprawiac playerem? :/